Contar celdas con formato condicional

Hola! Oye Aladino, a ver si me puedes echar un cable. Yo precisamente quiero contar el número de celdas que han sido coloreadas por un formato condicional. En este caso el formato condicional ha sido marcar las celdas con el número más grande, es decir, en reglas de formato "Aplicar formato a los valores que están en el rango en - Superior - 1".

Esto funcina sin problemas, y de cada columna me va marcando qué valor es el más elevado. Ahora quiero contar por filas cuál es la incidencia que más veces ha obtenido el valor más elevado, y no hay manera. No sé qué parámetro he de poner en el campo criterio de la función contar.si

En teoría, por lo ejemplos del excel y por lo que he visto por ahí, debería ser "1 superior", que es como se llama la condición del formato, pero nada... A ver si alguien me puede dar una idea.

Un saludo y muchas gracias ^_^

Miguel

En este caso, nuestro lector no establece un buen planteamiento. La norma general es que cuando aplicamos color de relleno a nuestras celdas, para contar hay que seguir el método indicado en este artículo. Cuando el formato se ha aplicado mediante formato condicional, a la hora de contar celdas por color o formato, tendremos que utilizar la fórmula utilizada en formato condicional. No obstante, en este caso concreto, no podemos utilizar ninguna de ambas soluciones, ya que el formato condicional se ha aplicado por columnas y nuestro lector desea obtener resultados por filas. Es decir, contar el número de celdas de color pero por filas.

Ponemos un ejemplo muy sencillo. Veamos la siguiente tabla a la cual hemos aplicado la regla Superior 1 del formato condicional.


Lo hemos hecho por columnas, seleccionando una columna

Inicio – Formato Condicional – Administrar reglas o directamente desde Nueva regla

Y seleccionamos la regla Aplicar formato únicamente a los valores con rango inferior o superior

Marcamos como porcentaje 1 en vez de 10

Hacemos clic en Aceptar

Las soluciones a este problema son múltiples ya que podemos utilizar fórmulas de distintos tipos.

=CONTAR.SI(B3:C3;MAX(B:B)+ CONTAR.SI(B3:C3;MAX(C:C)+CONTAR.SI(B3:C3;MAX(D:D)

=SI(B3=MAX($B$3:$B$5);1;0)+SI(C3=MAX($C$3:$C$5);1;0)+SI(D3=MAX($D$3:$D$5);1;0)

Creo que la más sencilla es la siguiente:

=(MAX($B$3:$B$5)=B3)+(MAX($C$3:$C$5)=C3)+(MAX($D$3:$D$5)=D3)

Escribimos esta formula en E3

Y la aplicamos hacia abajo al resto de filas

Si queremos escribir menos, podemos acortar creando previamente los nombres por cada columna

Pulsamos Ctrl+F3

En nuestro caso le damos el nombre maxim1
Establecemos que debe ser el máximo de la columna Valor 1. =MAX($B$3:$B$5)

Aceptamos y creamos otro nombre para la columna Valor 2 que llamamos maxim2

Aceptamos y creamos otro nombre para la columna Valor 3 denominado maxim3 siguiendo los pasos anteriores.

Y cerramos

Y escribimos nuestra fórmula usando dichos nombres:

=(maxim1=B3)+(maxim2=C3)+(maxim3=D3)

Podemos observar como ambas fórmulas dan resultados correctos.



Si tienes alguna duda sobre este artículo, crees que hay algo incorrecto (falta de ortografía, error en la imagen), una solución más sencilla o distinta, algo no te ha quedado claro o simplemente quieres saber más sobre ésta u otras funciones o posibilidades y no quieres dejar un comentario, rellena el Formulario de Contacto de la derecha.Te contestaré personalmente.

2 comentarios:

ROGELIO EDGAR CORTE NUÑEZ dijo...

hola del mismo ejemplo que has presentado pero sumando los valores que se encuentran en el formato condicional, ejemplo : 300 + 500

saludos

Claudia Castellano dijo...

Hola Edgar,

Una de las fórmulas posibles sería:

=SI(B3=MAX($B$3:$B$5);B3)+SI(C3=MAX($C$3:$C$53);C3)+SI(D3=MAX($D$3:$D$5);D3)

Publicar un comentario

Twitter Delicious Facebook Digg Stumbleupon Favorites More

 
Design by Free WordPress Themes | Bloggerized by Lasantha - Premium Blogger Themes | Top WordPress Themes